Raspberry Pi の Xubuntu で xfce4-dockbarx-plugin を使えるようにする

Raspberry Pi の Xubuntu では、xfce4-dockbarx-plugin がなぜかインストールできなかったので、依存関係を解決してビルドしたところ、正常に動作しました。

sudo addpapt-repository ppa:dockbar-main/ppa
sudo vi /etc/apt/sources.list.d/dockbar-main-ubuntu-ppa-xenial.list
-#deb-src http://ppa.launchpad.net/dockbar-main/ppa/ubuntu xenial main
+deb-src http://ppa.launchpad.net/dockbar-main/ppa/ubuntu xenial main
sudo apt-get update
sudo apt-get -y install debhelper libvala-dev valac libglib2.0-dev libgtk2.0-dev xfce4-panel-dev dockbarx-dockx dockbarx
mkdir build
cd build/
apt-get source xfce4-dockbarx-plugin
cd xfce4-dockbarx-plugin-0.4.1/
vi debian/control
-Build-Depends: debhelper, libvala-0.28-dev, valac-0.28, libglib2.0-dev, libgtk2.0-dev, xfce4-panel-dev, dockbarx-dockx, dockbarx
+Build-Depends: debhelper, libvala-0.30-dev, valac, libglib2.0-dev, libgtk2.0-dev, xfce4-panel-dev, dockbarx-dockx, dockbarx
dpkg-buildpackage -rfakeroot -uc -b
cd ../
sudo dpkg -i xfce4-dockbarx-plugin_0.4.1-1~webupd8~xenial2_armhf.deb

インストールが完了します。
ついでに、blueman というアプレットが異常終了するので、起動しないように設定しておきます。

blueman-off

一旦ログアウトして、ログインし直します。xfce4-dockbar-plugin をパネルに追加します。

dockbarx-add-1

dockbarx-add-2

dockbarx-add-3


コメントを残す

メールアドレスが公開されることはありません。

*

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください